Trivory is impacted by a Google Cloud service disruption

Incident Report for Trivory

Postmortem

Overview

All Trivory services (app, Trivory Dashboard, website, and Trivory for TVs) experienced a service disruption on Nov 3, 2025 starting at 3:00pm PST and ending at 4:36pm PST. During this period, all services were loading slowly and intermittently unavailable. The app remained partially available throughout, with the news feed and calendar still working. The Trivory Dashboard was unavailable for almost the entirety of the service disruption.

Cause

Trivory runs on Google Cloud and depends on one of their services, Firebase Realtime Database. This service experienced a global service disruption / outage, and as a result, Trivory and other companies were impacted. As of the time of writing, Google hasn’t acknowledged the service disruption or shared any additional details.

Posted Nov 03, 2025 - 19:20 PST

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 16:36 PST

Monitoring

The issue appears to be mostly resolved. We are continuing to monitor.
Posted Nov 03, 2025 - 16:31 PST

Update

The service disruption continues. The app and website still work, but load very slowly. The Dashboard and Trivory for TVs remain unavailable.
Posted Nov 03, 2025 - 15:46 PST

Update

Trivory depends on Google Firebase Realtime Database, which is experiencing a service disruption globally. We are waiting for Google to address the issue. In the meantime, some things are loading slowly or not at all. The issue is intermittent.
Posted Nov 03, 2025 - 15:37 PST

Update

Trivory is affected by an ongoing Google Cloud service disruption. Some things might load slowly or not at all. Most features except for the news feed and calendar are affected.
Posted Nov 03, 2025 - 15:20 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 03, 2025 - 15:15 PST

Investigating

We are currently investigating this issue.
Posted Nov 03, 2025 - 15:12 PST
This incident affected: App, Website, Dashboard, and Trivory for TVs.